You are viewing outdated content for BUG. If you have a BUG Y.T. edition or 2.0 series device, please visit our updated wiki: http://wiki.buglabs.net



SDK Install Guide

From BUG Wiki

Jump to: navigation, search

Contents

Overview

Dragonfly (the BUG SDK) comes with the Virtual BUG, a built-in emulator that allows you to quickly test drive your applications in a controlled environment without BUG hardware. Through the BUG SDK you can access the BUGnet community where you can browse, share and collaborate.

This page has two sets of instructions for installing Dragonfly.

  • the Full Install—the latest versions of both Dragonfly and Eclipse, bundled together. This is the easiest way to install Dragonfly and is useful if you're new to Eclipse or only plan to use Eclipse for BUG development.
  • using the Update Site—If you're an existing Eclipse user, or you are running a 64-bit operating system, you can install Dragonfly as an Eclipse plugin via our Update Site.


NOTE: If you are using a 64-bit operating system, then you must use the Update Site method of installing Dragonfly.


Prerequisites

Dragonfly is built on Eclipse Classic SDK, an open development platform written in Java. Eclipse Classic can be used on Windows, Linux, and Mac platforms.

  • Dragonfly is compatible with Eclipse version 3.3 or greater, but we recommend version 3.5. If you are not using this version, you can download and install Eclipse.
    • Eclipse Classic requires Java 1.5 or higher. If you are not using this version, you can download Java now.
    • On Linux, you may need to install xulrunner for the browser view to work inside Eclipse. On a Debian or Ubuntu distribution, install like this: sudo apt-get install xulrunner


Full Install Instructions

Step 1: Download the correct zip file for your platform

  • Download the appropriate file:
  • Extract the file to whatever location is convenient
    • In Linux, /opt or ~/bin are common places to put Eclipse
    • The extracted folder will be called eclipse
  • Eclipse requires no installation. Open the extracted folder and click eclipse to run.


Step 2: Change your Perspective to Dragonfly

  • In Eclipse, go to Window > Open Perspective > Other...
    • In the Open Perspective window, click on Dragonfly to select it.
    • Click OK.

  • Or, click on the Dragonfly or Java perspective icon in the upper-right-hand corner of the Eclipse workspace.


Update Site Instructions

These instructions assume you already have Eclipse version 3.4 or 3.5.


Step 1: Install the Dragonfly Plugin on Eclipse 3.5

  • If you are installing Dragonfly on Eclipse 3.4, see #Step 1: Install the Dragonfly Plugin on Eclipse 3.4
  • In Eclipse, go to Help > Install New Software.
  • On the right side, select the Add... button to open the Add Site dialog.
  • Enter the Dragonfly Update Site url into the Location box:
http://buglabs.net/sdk/production/current/updatesite/
  • Click OK.
  • An item will appear in the Available Software listing the "Dragonfly SDK".
  • Select the checkbox to the left of Dragonfly SDK.
  • Click the Next > button on the bottom of the dialog.
  • A progress bar should appear.
  • After a few seconds, the Install Details dialog will appear. One item, Dragonfly SDK, should be listed.
  • Click Finish.
  • Eclipse will detect and install a dependency called the Graphical Editing Framework if you don't already have it.
  • A progress bar will appear as Eclipse downloads and installs the plugins.
  • When installation is complete, Eclipse will ask if you would like to restart.
  • Click No, then close and start Eclipse manually.
  • Once started Change to the dragonfly perspective.
  • Proceed to Step 2.


Step 1: Install the Dragonfly Plugin on Eclipse 3.4

  • In Eclipse, go to Help > Software Updates.
  • On the Software updates and Add-ons dialog, select the Available Software tab.
  • On the right column, select the Add Site... button to open the Add Site dialog.
  • Enter the Dragonfly Update Site url into the text box:
http://buglabs.net/sdk/production/current/updatesite/
  • Click OK.
  • An item will appear in the Available Software list matching the above URL. Expanding that item will show a child item called Dragonfly.
  • Select the checkbox to the left of the URL. All child items should also be selected.
  • Click the Install... button on the upper right side of the dialog.
  • A progress bar should appear.
  • After a few seconds, the Install dialog will appear. One item, Dragonfly, should be listed and checked.
  • Click Next.
  • Eclipse will detect and install a dependency called the Graphical Editing Framework. You should see this listed in the following dialog if you don't already have it installed.
  • Accept the terms of the license agreement and click Finish.
  • A progress bar will appear as Eclipse downloads and installs the plugins.
  • When installation is complete, Eclipse will ask if you would like to restart.
  • Click No, then close and start Eclipse manually.
  • Once started Change to the dragonfly perspective.


Step 2: Change your Perspective to Dragonfly

  • In Eclipse, go to Window > Open Perspective > Other...
  • In the Open Perspective window, click on Dragonfly to select it.
  • Click OK.

Install Dragonfly on Eclipse 3.3

These steps are for first-time Eclipse & Dragonfly installations only.


Step 1: Install Graphical Editing Framework 3.3.0.

  • Launch Eclipse.
  • Go to File > Switch Workspace > Other ...
  • In the Workspace Launcher, create a workspace similar to this: \Users\UsersName\Desktop\BUG\Workspace
  • Go to Help > Software Updates > Find and Install
  • In the Install/Update step, select Search for new features to install, then click Next.
  • In the Install step, select Europa Discovery Site, then click Finish.
  • In the Update Site Mirrors pop-up, select a download site, or mark the Automatically select mirrors checkbox.
  • Click OK.
  • In the new Updates window, make sure the "Filter features included in other features on the list" is unchecked.
  • Click the arrow to open the Europa Discovery Site node.
  • Click the arrow to open the Graphical Editors and Frameworks node.
  • Mark the checkbox for Graphical Editing Framework 3.3.0—not the "SDK" version.
  • Click Next.
  • Below the Feature License, select I accept the terms in the license agreement, then click Next.
  • Click Finish.


Step 2: Install the BUG SDK

  • In Eclipse, go to Help > Software Updates > Find and Install.
  • In the Install/Update step, select Search for new features to install, then click Next.
  • In the Install step, click New Remote Site.
  • In the Name form field, type: BUG SDK
  • In the URL form field, type: http://www.buglabs.net/sdk/production/current/updatesite/
  • Click OK.
  • In the Install/Update step, select BUG SDK.
  • Select Finish.
  • Select the checkbox next to BUG SDK
  • Select Next
  • Select the radio button I accept the terms in the license agreement
  • Select Next
  • Select Finish
  • At the prompt, select Install All
  • Select Yes to restart Eclipse


Need More Help?

Browse the pages for BUG developers for more resources, or contact us.