Bug Labs Home First Last Prev Next    No search results available
Details
: Problems getting HTTP server / debugger running on FC8
Bug#: 86
: SDK
: BUGnet
Status: CLOSED
Resolution: Cannot Reproduce
: PC
: Windows XP
: 266
: P3
: normal

:
Eclipse Version: 3.3
Version Verified In:
:
:
  Show dependency tree - Show dependency graph
People
Reporter: Melinda Caric <melinda@buglabs.net>
Assigned To: Alex Kravets <alex@buglabs.net>
: QA <qa@buglabs.net>
:

Attachments


Note

You need to log in before you can comment on or make changes to this bug.

Related actions


Description:   Opened: 2008-01-30 16:15
Problems getting HTTP server / debugger running on FC8

From finsprings:

I have been making some updates to BUGer and ran into a few problems. When I
start the VIrtualBug in release mode I get:
Tue Jan 29 23:13:29 EST 2008] [ERROR] Exception during sending of SRVREG -
xid=25528, locale=, url: service:bug://192.168.13.122:8082, serviceType:
service:bug, scopeList: [default], attList: []
[Tue Jan 29 23:13:29 EST 2008] [ERROR] to localhost.localdomain/127.0.0.1:1427
[Tue Jan 29 23:13:29 EST 2008] [ERROR] Exception:
Exception: Receive timed out
[Tue Jan 29 23:13:29 EST 2008] [ERROR] Receive timed out
STARTING
file:/home/dave/dev/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.266/kernel/com.buglabs.osgi.shell.jar
ch.ethz.iks.slp.ServiceLocationException: Receive timed out
at ch.ethz.iks.slp.impl.SLPCore.sendMessage(SLPCore.java:719)
at ch.ethz.iks.slp.impl.AdvertiserImpl.register(AdvertiserImpl.java:128)
at ch.ethz.iks.slp.impl.AdvertiserImpl.register(AdvertiserImpl.java:101)
at com.buglabs.bug.slp.Activator.start(Activator.java:47)
at ch.ethz.iks.concierge.framework.BundleImpl.startBundle(BundleImpl.java:446)
at
ch.ethz.iks.concierge.framework.Framework$SystemBundle.setLevel(Framework.java:2290)
at
ch.ethz.iks.concierge.framework.Framework$SystemBundle.access$0(Framework.java:2255)
at ch.ethz.iks.concierge.framework.Framework.startup(Framework.java:456)
at ch.ethz.iks.concierge.framework.Framework.main(Framework.java:313)

a few seconds after it starts. It is unable to open the HTTP service port 8082
for some reason. This port isn't already opened, so I'm not sure why it's
having trouble. I don't get any SELinux popups or anything.


I looked at the PDE error log and I see:

Error occured while updating MyBUGS model.
ch.ethz.iks.slp.ServiceLocationException: Connection timed out
at ch.ethz.iks.slp.impl.SLPCore.sendMessageTCP(Unknown Source)
at ch.ethz.iks.slp.impl.SLPCore.multicastConvergence(Unknown Source)
at ch.ethz.iks.slp.impl.LocatorImpl.sendRequest(Unknown Source)
at ch.ethz.iks.slp.impl.LocatorImpl.findServices(Unknown Source)
at com.buglabs.dragonfly.util.SLPListener.getBugs(Unknown Source)
at com.buglabs.dragonfly.util.BugListener.run(Unknown Source)

and:

Unable to initialize jSLP
ch.ethz.iks.slp.ServiceLocationException: Connection timed out
at ch.ethz.iks.slp.impl.SLPCore.sendMessageTCP(Unknown Source)
at ch.ethz.iks.slp.impl.SLPCore.multicastConvergence(Unknown Source)
at ch.ethz.iks.slp.impl.LocatorImpl.sendRequest(Unknown Source)
at ch.ethz.iks.slp.impl.LocatorImpl.findServices(Unknown Source)
at com.buglabs.dragonfly.ui.Activator.forceLazyLoadingAndJSLPInit(Unknown
Source)
at com.buglabs.dragonfly.ui.Activator.start(Unknown Source)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
at java.security.AccessController.doPrivileged(Native Method)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
at
org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
at
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
at
org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:417)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:408)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
at
org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
at java.lang.ClassLoader.loadClass(ClassLoader.java:269)
at
org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass(BundleLoader.java:289)
at
org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:227)
at
org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1269)
at
org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:160)
at
org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:788)
at
org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
at
org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:51)
at
org.eclipse.ui.internal.navigator.filters.CommonFilterDescriptor.createFilter(CommonFilterDescriptor.java:120)
at
org.eclipse.ui.internal.navigator.NavigatorFilterService.getViewerFilter(NavigatorFilterService.java:178)
at
org.eclipse.ui.internal.navigator.NavigatorFilterService.getVisibleFilters(NavigatorFilterService.java:148)
at
org.eclipse.ui.navigator.CommonNavigator.createPartControl(CommonNavigator.java:164)
at
org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:370)
at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:227)
at
org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:592)
at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:299)
at org.eclipse.ui.internal.ViewPane.setVisible(ViewPane.java:531)
at
org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:179)
at
org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:268)
at
org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)
at
org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:400)
at
org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1256)
at org.eclipse.ui.internal.PartStack.createControl(PartStack.java:668)
at org.eclipse.ui.internal.PartStack.createControl(PartStack.java:576)
at
org.eclipse.ui.internal.PartSashContainer.createControl(PartSashContainer.java:564)
at
org.eclipse.ui.internal.PerspectiveHelper.activate(PerspectiveHelper.java:270)
at org.eclipse.ui.internal.Perspective.onActivate(Perspective.java:931)
at org.eclipse.ui.internal.WorkbenchPage.onActivate(WorkbenchPage.java:2515)
at org.eclipse.ui.internal.WorkbenchWindow$23.run(WorkbenchWindow.java:2837)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:67)
at
org.eclipse.ui.internal.WorkbenchWindow.setActivePage(WorkbenchWindow.java:2818)
at
org.eclipse.ui.internal.WorkbenchWindow$17.runWithException(WorkbenchWindow.java:2135)
at
org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3296)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2974)
at
org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:801)
at org.eclipse.ui.internal.Workbench$25.runWithException(Workbench.java:1342)
at
org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3296)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2974)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2309)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:623)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)

It seems to have other troubles too: when I hit Escape in the virtual bug I
see:

STOPPING
file:/home/dave/dev/eclipse/plugins/com.buglabs.dragonfly.bug.kernel_1.0.0.266/kernel/com.buglabs.osgi.http.jar

in the console and the GUI disappears, but the java process is still running. I
am also unable to start the Virtual Bug with the debugger. When I try that the
"operation in progress" dialog stays up for quite a while and then it says it
can't launch the bug. The PDE error log shows:

Unable to launch VirtualBug
org.eclipse.core.runtime.CoreException: Cannot connect to VM
at org.eclipse.jdt.launching.AbstractVMRunner.abort(AbstractVMRunner.java:47)
at
org.eclipse.jdt.internal.launching.StandardVMDebugger.run(StandardVMDebugger.java:327)
at
com.buglabs.osgi.concierge.launch.ConciergeLaunchConfiguration.launch(Unknown
Source)
at
com.buglabs.dragonfly.launch.VirtualBugLaunchConfigurationDelegate.launch(Unknown
Source)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:766)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:608)
at
org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:601)
at com.buglabs.dragonfly.ui.launch.VirtualBugLaunchShortCut.launch(Unknown
Source)
at com.buglabs.dragonfly.ui.launch.VirtualBugLaunchShortCut.launch(Unknown
Source)
at
org.eclipse.debug.internal.ui.launchConfigurations.LaunchShortcutExtension.launch(LaunchShortcutExtension.java:429)
at
org.eclipse.debug.internal.ui.actions.LaunchShortcutAction.run(LaunchShortcutAction.java:66)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
at
org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:546)
at
org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:490)
at
org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:402)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1101)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3319)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2971)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2389)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)
at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:169)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:623)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
org.eclipse.core.runtime.CoreException[120]:
com.sun.jdi.connect.TransportTimeoutException
at
org.eclipse.jdi.internal.connect.SocketTransportService.accept(SocketTransportService.java:97)
at
org.eclipse.jdi.internal.connect.SocketTransportImpl.accept(SocketTransportImpl.java:56)
at
org.eclipse.jdi.internal.connect.SocketListeningConnectorImpl.accept(SocketListeningConnectorImpl.java:135)
at
org.eclipse.jdt.internal.launching.StandardVMDebugger$ConnectRunnable.run(StandardVMDebugger.java:106)
at java.lang.Thread.run(Thread.java:675)


This happens with the built-in java 1.7 that comes with FC8 and with a manual
download of 1.6.0._04. This is with Eclipse SDK Version: 3.3.1.1, Build id:
M20071023-1652

Any ideas?
------- Comment #1 From Alex Kravets 2008-01-30 19:05:59 -------
I will take a look at this
------- Comment #2 From Ken Gilmer 2008-04-14 15:06:55 -------
Dave,

  If you are still having this problem can you copy and paste the full
Concierge console output from when the Virtual BUG is started?

thx
ken
------- Comment #3 From QA 2008-09-12 15:32:47 -------
Unable to reproduce.
thanks, h
------- Comment #4 From QA 2008-09-12 15:33:00 -------
thanks, h

First Last Prev Next    No search results available