Bug Labs Home First Last Prev Next    No search results available
Details
: VB: After adding LCD module menu navigation slows way down
Bug#: 311
: SDK
: Virtual BUG
Status: CLOSED
Resolution: FIXED
: PC
: Windows XP
: 320
: P3
: normal

:
Eclipse Version: ---
Version Verified In:
:
:
  Show dependency tree - Show dependency graph
People
Reporter: Brian Cruskie <brianc@buglabs.net>
Assigned To: Brian Ballantine <brian@buglabs.net>
: Brian Cruskie <brianc@buglabs.net>
:

Attachments


Note

You need to log in before you can comment on or make changes to this bug.

Related actions


Description:   Opened: 2008-11-17 17:35
VB: After adding modules menu navigation slows way down

 Repro'd on two Winxp machines (will ask MC to test Vista)

STR
1. Launch VB with no modules
2. Navigate the status bar menu structure, it should be fast and responsive
3. Add LCD module to any slot

Actual Results: Status bar navigation slows way down when delving into the menu
nodes.
Expected Results: Status bar navigation is fast when delving into the menu
nodes
------- Comment #1 From Melinda Caric 2008-11-17 17:52:49 -------
Tested this on Vista and there are no issues to report, the menu responds as
expected.
------- Comment #2 From Alex Kravets 2008-11-22 17:47:50 -------
Tested this on XP and menu functions as expected. Melinda, can you please
retest this on XP and reopen if problem exists.
------- Comment #3 From Melinda Caric 2008-11-24 13:54:13 -------
I was unable to reproduce this on my XP environment, but Brian C is still
seeing these issues on both of his XP machines.
------- Comment #4 From Brian Cruskie 2008-11-26 09:39:27 -------
Still an issue on my winxp machines. Melinda reproduced this on Winxp and
showed Alex. Any updates?
------- Comment #5 From Ken Gilmer 2009-01-27 16:45:53 -------
The stream multiplexer reads from inputstream, and if -1 is passed continues to
try to read.  In VB a sample file is used to simulate hardware, but then after
awhile the file data is exhaused.  -1 is always returned from read() at this
point resulting in an infinite loop condition.  There is a built-in 'read
delay', the fix was to use the appropriate constructor to set the read delay to
a sane value.
------- Comment #6 From Ken Gilmer 2009-01-27 16:46:11 -------
This defect effects both motion and lcd modules as they both have
accelerometers.
------- Comment #7 From Brian Cruskie 2009-01-29 10:15:55 -------
bballantine,

Could you get this into the current testing SDK build please?

Thanks,

BC
------- Comment #8 From Brian Cruskie 2009-02-11 21:41:39 -------
Verified fix in build 1.2.6.2

First Last Prev Next    No search results available